问题现象

yum 安装gcc 时,提示glibc错误依赖

错误:软件包:glibc-devel-2.17-307.el7.1.x86_64 (Nginx-yum)
          需要:glibc = 2.17-307.el7.1
          已安装: glibc-2.17-326.el7_9.x86_64 (@anaconda)
              glibc = 2.17-326.el7_9
          可用: glibc-2.17-307.el7.1.x86_64 (Nginx-yum)
              glibc = 2.17-307.el7.1
错误:软件包:glibc-headers-2.17-307.el7.1.x86_64 (Nginx-yum)
          需要:glibc = 2.17-307.el7.1
          已安装: glibc-2.17-326.el7_9.x86_64 (@anaconda)
              glibc = 2.17-326.el7_9
          可用: glibc-2.17-307.el7.1.x86_64 (Nginx-yum)
              glibc = 2.17-307.el7.1
错误:软件包:gcc-4.8.5-39.el7.x86_64 (Nginx-yum)
          需要:libgomp = 4.8.5-39.el7
          已安装: libgomp-4.8.5-44.el7.x86_64 (@anaconda)
              libgomp = 4.8.2-16.el7
              libgomp = 4.8.5-44.el7
          可用: libgomp-4.8.5-39.el7.x86_64 (Nginx-yum)
              libgomp = 4.8.5-39.el7
              libgomp = 4.8.2-16.el7

解决

文字中已经很清晰的说明了需要的版本和已经安装的版本,说明版本高了,需要手动降级

//降级安装
yum downgrade -y glibc glibc-common libgomp

//再次执行,完美执行成功
yum install -y gcc